Degraded Performance

Incident Report for RosySalonSoftware

Resolved

This incident has been resolved. We apologize for any inconvenience!
Posted Jul 01, 2025 - 14:40 CDT

Monitoring

A fix has been implemented and we are monitoring the results. Please refresh Rosy or log back in if you still seem to be experiencing any issues. We apologize for any inconvenience.
Posted Jul 01, 2025 - 13:46 CDT

Identified

The issue has been identified and a fix is being implemented
Posted Jul 01, 2025 - 13:06 CDT

Investigating

We are currently investigating degraded performance for some users within Rosy.
Posted Jul 01, 2025 - 12:39 CDT
This incident affected: Manager.