Schedule access
Incident Report for RosySalonSoftware
Resolved
This incident has been resolved and the schedule is now working. We apologize for any inconvenience.
Posted Nov 26, 2024 - 08:38 CST
Investigating
We are currently investigating an issue with navigating to the Schedule
Posted Nov 26, 2024 - 08:30 CST
This incident affected: Manager.